Target, Datacare and Connect applications are not available.
Incident Report for Dealfront
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 05:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 19, 2023 - 05:06 UTC
This incident affected: Target Pro, Connect, and Datacare.