Problems with platform availability

Incident Report for Dealfront

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 10:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 09:32 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 21, 2025 - 09:24 UTC

Investigating

We are currently investigating this issue.
Posted Mar 21, 2025 - 09:16 UTC
This incident affected: Platform and Leadfeeder.