Echobot API is currently down

Incident Report for Dealfront

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 13:04 UTC

Investigating

We are investigating the issue
Posted Nov 13, 2025 - 12:47 UTC
This incident affected: Echobot API.