Target Pro: Issues with Website and Industry related searches
Incident Report for Dealfront
Resolved
The issue has been resolved. Website and Industry related searches should be working again normally
Posted Oct 26, 2023 - 13:09 UTC
Investigating
We are experiencing general issues with the Target Pro related to Website and Industry related searches. Users may experience empty results while using related filters to these searches.
Posted Oct 26, 2023 - 12:25 UTC
This incident affected: Target Pro.