The Leadfeeder Tracker is experiencing degraded performance. We are investigating and a fix should be expected soon.
Incident Report for Dealfront
Resolved
This incident as been resolved.
Posted Apr 18, 2024 - 13:37 UTC
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 13:36 UTC
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 13:36 UTC
Investigating
We are currently investigating this issue.
Posted Apr 18, 2024 - 12:05 UTC
This incident affected: Tracker.