Reports of Target Pro not being available to some users
Incident Report for Dealfront
Resolved
This incident has been resolved.
Posted Sep 27, 2023 - 09:47 UTC
Identified
We've identified an issue preventing some users access to Target Pro. We are currently working on a fix
Posted Sep 27, 2023 - 07:18 UTC
This incident affected: Target Pro.