Incident with Target Pro
Incident Report for Dealfront
Resolved
This incident has been resolved.
Posted Aug 22, 2023 - 11:12 UTC
Identified
Target Pro is unavailable. We have identified the root cause and working on an fix
Posted Aug 22, 2023 - 10:00 UTC
This incident affected: Target Pro.